Un investigador de seguridad conocido para encontrar errores de Java ha descubierto un nuevo crítico día cero en todas las versiones actualmente soportadas del popular software de Oracle.

El fallo, que se informó públicamente por Adam Gowdiak, fundador y CEO de la firma polaca Security Explorations, se puede aprovechar para secuestrar una máquina equipada con Java, dejando que los atacantes puedan instalar malware en el sistema.

PCs con Windows y Macs tienen el mismo riesgo si sus usuarios han instalado Java, o en el caso de OS X, si ejecuta su versión Snow Leopard o anterior. Snow Leopard fue la última edición en la que Apple incluía Java con el sistema operativo.

Todas las versiones actuales de Java, incluyendo Java 5, Java 6 y Java 7, contienen el error.

Gowdiak ha encontrado otras vulnerabilidades de Java en el pasado: A principios de este año reportó más de una docena a Oracle. Meses más tarde, los hackers descubrieron de forma independiente uno de los errores y comenzaron a usarlo en ataques generalizados en agosto pasado.

“El impacto potencial es mayor cuando se trata de la cantidad de escritorios de Java”, dijo Gowdiak en una respuesta por correo electrónico a las preguntas. “La vulnerabilidad afecta las instalaciones de Java 5, 6 y 7. Incluso probe la vista previa para desarrolladores de Java 7 Update 10, una construcción del 20 de septiembre [y] también fue verificada vulnerable”.

Gowdiak, utilizando la base de estadísticas citadas por Oracle, sostuvo que aproximadamente mil millones de usuarios de computadores están en riesgo debido a la vulnerabilidad sin parchar.

El hecho de que Java 6 es vulnerable será de especial interés para cualquier persona que utilice un Mac que ejecuta OS X 10.6 (Snow Leopard) o OS X 10.5 (Leopard). Aunque Apple dejó Java con OS X a partir de 2011, Snow Leopard y Leopard incluyeron el software.

En vista de ello, Gowdiak instó a los usuarios desactivar el plug-in en su navegador hasta que Oracle anuncie un parche.

Más detalles en: Computer World